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Saturday, 27 January 2024 11:36

Veeam backup fail after Windows Update

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Issue

My local backup is using 'Veeam Endpoint for Windows' and an external USB Hard Drive which were working fine until after a Windows Update. It took a while before I worked out the link between the update and Veeam.

I would get errors like these shown below.

Error: Full backup file merge failed

26/01/2024 18:09:41 :: Full backup file merge failed Error: Agent: Failed to process method {Transform.Patch}: The media is write protected.

Error: Asynchronous read operation failed

26012024 215538  Error The device is not ready. Asynchronous read operation failed Failed to upload disk. Agent failed to process method {DataTransfer.SyncDisk}. Exception from server The device is not ready. Unable to retrieve next block transmission command. Number of already processed blocks [86184]. Failed to download disk 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx'

Cause

After a Windows Update, there was something wrong with the mount point for the 'Recovery Partition' because the update had corrupted the partition somehow. Because of this corruption, Veeam cannot correctly mount the 'Recovery Partition' so the backup fails.

Solution

Mount and Unmount the 'Recovery Partition' (Add and Remove a drive letter)

  • What this seems to do is fix the mount point for the partition and this allows Veeam to complete it's backup.
  • When I added a drive letter I found there were no files on my 'Recovery Partition'.
  • There are many different ways you can do this but here are a few:
    • diskpart (via cmd)
    • Powershell
    • Install a partition manager into Windows.
    • Boot from a partition manager, assign a drive letter, load Windows, boot from the partition manager again and remove the drive letter.

The backup will show a success message as follows:

Research

Read 115 times Last modified on Saturday, 27 January 2024 12:25