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Monday, 17 November 2014 00:00

Cannot send emails to Yahoo from my Joomla Website

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When configuring a joomla's website email settings (or other email app) you can add a clients email address as the 'From email' (joomla admin / System /  Global Configuration / Server / From email ) and usually when you do this, joomla sends the email as if their email had sent it, and then client receives it.  With yahoo this does not happen

Cause

Yahoo will not accept email from other email servers proporting to be yahoo. They enforce SPF and so i cannot spoof an email address to send email yahoo or possibly other email address.

Read this from yahoo - Help Central | - SLN7253 - Error "554 5.7.9: Message not accepted for policy reasons" when sending email to Yahoo

This might also apply to other email companies ie. Google and Bing, if not now probably shortly.

Solution

The fix is to set the 'Mail From' with valid email address on your domain. You can then set an alternative reply address to accomodate for cutomers who use yahoo/bing/google email accounts exclusively. The email will come from the email from their domain but if you set the 'subject' with something like 'website enquiry' you can set an antispam rule to prevent the email getting filed in their junk folder.

Notes for cPanel

  • you might be able to send emails from any address on your domain without creating a real account
  • if you set up a forwarder, be aware that some companies (hostdime) will run CRON jobs to delete forwarders to the providers of free email addresses such as Yahoo!, AT&T, AOL, and MSN/Live/Outlook.com/HotMail. (possibly google/outlook/yahoo). This prevents their servers getting blacklisted by these providers.

Joomla

(joomla admin / system /global configuration / server / mail settings)

  • Mailer - leave as PHP Mail, Sendmail does not work
  • From Email - set as no-reply@yourjoomladomain.com, this does not require a forwarder or mailbox but make sure the catch all account is off. But you can use a real address if you want.
  • From Name - Set as normal

JSN Uniform (additional)

These step are not require for the email to work but allow the reply option to work as intended

  • open uniform
  • edit the contact form
  • go to the 'Action' tab
  • click on the 'email edit' button next to 'Send to email(s)'
    •  From          - This is the From Name and not the sending email address so I insert the customers name field here.
    •  Reply To    - click on the '...' button and select 'Email', this will set the reply address as the contact form senders address
    •  Subject     - This is not required to fix the email issue but makes things look neater. type 'From Website - ' then click the  button and select 'Subject'
Read 1086 times Last modified on Wednesday, 04 May 2016 15:57