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Sunday, 16 November 2008 14:47

SBCMSYNC.DLL is not a valid Office Add-In

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Usually after an upgrade form Office 2000 to Office 2003 this problem occurs because of the bussiness contacts manager Add-in. Other Add-ins might cause a similiar issue, The error message will be similiar to:

C:\Documents and Settings\Administrator\ApplicationData\Microsoft\AddIns\C:\Program Files\Microsoft Office\Office 11\SBCMSYNC.DLL is not a valid Add-In.

Also, a client after moving a hard drive from an older Windows 98 PC to a newer Windows XP PC receives this error message whenever he opens Microsoft Outlook 2003. However, he can close the messages by clicking OK and carry on using Outlook.

Cause

The file in question, Sbcmsync.dll, is affiliated with SBCM (Small Business Customer Manager), an information management tool that comes bundled with Microsoft Office. It appears that Outlook 2003 is attempting to access the SBCM but can’t find it, probably because of coding confusion that relates back to the user-initiated drive migration.

Solution 1 - Quick

  1. Navigate to the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\SBCM.ADDIN.1
  2. Delete the Key

Solution 2

Disable the offending add-in(s)

The key to resolving this issue is eliminating all references to the SBCM, which means accessing Outlook's Options dialog box. The can be done by:

  1. Opening the Tools menu
  2. Click Options
  3. Choosing the Other tab
  4. Select Advanced Options.
  5. click the Add-In Manager button and deselect any reference to SBCM or Outlook Sync in the resulting dialog box.
  6. Click OK
  7. Return to the Options dialog box, and repeat the process with the COM Add-Ins option.

Delete the Extend.dat file because it’s involved in the deployment of Office add-ins, and this error may occur if that file is corrupted:

  1. Using WinXP’s Search utility  find the file the system
  2. Rename to extend.old
  3. Reboot PC
  4. After system restarts, delete the extend.old file.

Clean the registry:

Backup your registry Registry (as a safety precaution in case something goes wrong)

Remove any references to SBCM that remain there. You can do that by:

  1. Open regedit
  2. Locate the following keys
    HKEY_CURRENT_USER\SOFTWARE\MICROSOFT\OFFICE\OUTLOOK\ADDINS

    and

    HKEY_CURRENT_ USER\SOFTWARE\MICROSOFT\OFFICE\11.0\OUTLOOK\ADDINS
  3. Delete any value or subkey referring to SBCM.

That ought to take care of the issue. The last resort would be to uninstall Microsoft Outlook and reinstall it from scratch.

Read 1128 times Last modified on Sunday, 01 November 2015 13:31